What is Dreamweaver MX?

Dreamweaver MX is a powerful, yet flexible site management tool that helps you with the process of creating and managing Web pages and sites. Using a graphical interface you can quickly put together a page of text, images, and hypertext links. The page can be designed with colors, tables, styles, graphics, and menus to make it functional and attractive. However, be forewarned that Dreamweaver can not prevent you from making unattractive pages. Making professional looking pages requires practice, browsing other sites for ideas, listening to feedback, and lots of time. This tutorial covers intermediate techniques that are outlined in the next section.

What you will learn

In Intermediate Dreamweaver MX, you will learn to:

- define a Dreamweaver site (review)
- create a page from a Word document
- lay out images and text side-by-side
- create and format tables (review)
- apply styles to your page
- use the tag selector
- apply templates to pages
- insert Library items
- attach captions to tables
- wrap images around text
- create a complex table
- create outside table borders
- insert Quicktime movies
- calculate the size of your page

What you will need to know before starting this tutorial

- You should have recently (redo it if necessary) completed the Dreamweaver Basics tutorial.

- You should have experience with at least one application such as Microsoft Word and know how to open and save files.

Tutorial conventions

When working through this guide, please read carefully the explanations and background information. Action steps that require working directly with Dreamweaver are denoted with this symbol ▶

For example, to create a page in Design View you would follow these steps:
Choose **File > New ...**

- Click the General tab, click Basic Page under Category, click HTML under Basic Page, and click Create.

When the tutorial refers to pressing the Enter key, the implication is that the Return key should be pressed for Macintosh computers.

In some sections, there is a reference to the figure “below”. The search for the figure name may extend from as little as one paragraph below to the next page or two.

### Map Your W Drive

#### Windows

- Log on to a Windows computer with your Eaglenet (ANGEL) username and password.
- Double-click My Computer to display the available network drives.
- Double-click the W drive to open it into a window on the desktop.

#### Macintosh

- Log on to a Macintosh computer by entering `macuser` in the Username and Password boxes.
- Click the **W Drive** icon in the Dock.
- Type your Eaglenet username in the dialog box and click **OK**.
- Another window will appear. Make sure that the **Workgroup/Domain** is **Eaglenet**, verify your username, and type your password (lowercase). Click **OK**.
- Your W drive window will now open and an icon will appear on the desktop titled with your username.

### Copying the Tutorial Folder to Your W Drive

#### Windows

- Right-click on **Network Places** and choose **Map Network** drive.
- Choose the drive letter **R** in the **Drives** box and type `\cowles\dwtrain` in the network

#### Macintosh

- Choose **Go > Connect to Server**.
- Type `smb://cowles/dwtrain` in the Server Address box.
- Click **Connect**.
- Type your Eaglenet username and click **OK**.
Folder box.  
- Do not check Reconnect at logon.  
- Click the Finish button.
  The dwtrain share opens into a window on the desktop.
  If a mysite folder already exists, you can rename it if you wish.

- Another window will appear. Make sure that the Workgroup/Domain is Eaglenet, verify your username, and type your password (lowercase). Click OK.
  The dwtrain share opens into a window on the desktop.

- Open the intermediate folder.
- Drag the folder mysite to your W drive. If mysite exists on your drive, you can replace the folder or rename it.

---

Copying mysite folder

---

Defining a Dreamweaver Web Site

Dreamweaver requires that you designate a working folder of HTML files, images, media files, PDF documents, and other related documents as a site before

You will define your mysite folder as a Dreamweaver site and edit the site directly on your W drive. Your site is considered a Local site.

- Choose Apple menu (Macintosh) or Start Menu (Windows) > Internet or Internet Applications > Dreamweaver.
- A window titled “Workspace Setup” may appear. Click OK.
  It may take a few moments for Dreamweaver MX to load.
Intermediate Dreamweaver MX

Windows

- Choose Site > New Site.
- Click on the Advanced tab.
- Under Category select Local Info.
- Type My Second Site in the Site Name box.
- Click the small folder icon to the right of the Local Root Folder box and browse to your mysite folder in your W drive.
- Click the mysite folder and the click the Select button. The Local Root folder text box should now read: W:\mysite.

Macintosh

- Choose Site > New Site.
- Click on the Advanced tab.
- Under Category select Local Info.
- Type My Second Site in the Site Name box.
- Click the small folder icon to the right of the Local Root Folder box and browse to your mysite folder in your W drive.
- Click the mysite folder and the click the Select button.

The Local Root folder text box should now read: mtwain08$:mysite.

- Click the OK button.

Your Dreamweaver site is now defined and displays in the Site window. Depending on the computer you are using, refer to the figure Site view for Macintosh or Site view for Windows. Included in your site are HTML files, a folder of images, a folder of non HTML
files such as Word documents, and special folders (Templates, Library, and includes) that are used for site management.

Your Dreamweaver site is now defined and displays in the Site window. Depending on the computer you are using, refer to the figure Site view for Macintosh or Site view for Windows. Included in your site are HTML files, a folder of images, a folder of non HTML files such as Word documents, and special folders (Templates, Library, and includes) that are used for site management.

**Dreamweaver Preferences**

You will customize Dreamweaver settings in order to more easily complete this tutorial.

- Choose *Edit > Preferences*.
- Choose *General* under Category and then uncheck *Show Only Site Window on Startup*. 
Preferences

Under Category, choose **Invisible Elements** and check the **Line Breaks** box.

Then choose **Code Hints** and uncheck **Enable Auto Tag Completion**

Finally choose **Preview in Browser** and choose **Firefox** as the Primary Browser

Click **OK**.

Creating a Dreamweaver Page from a Word Document

There are a number of ways to bring text from Microsoft Word into your Web page. A simple copy and paste from Word to Dreamweaver is the most intuitive method and works for most cases.

1. Choose **File > New …**
2. Choose the **General** tab, choose Basic Page under Category, choose HTML under Basic Page, and click Create.
3. Make sure that the Show Design View button is selected.
4. Type **ENIAC Women** in the Title box.
5. **Save your Web page**
   - Choose **File > Save** and navigate to your folder `dwtrain:intermediate:mysite_mtwain` (Macintosh) or `R:\intermediate:mysite_mtwain` (Windows).
   - Type the filename `eniac_women.html` in the File Name box and click the **Save** button.
   - In your site window open the folder **nonweb** and double-click the document `eniac_women.doc`, which will open into Microsoft Word.
In the Word document choose **Edit > Select All.** Then choose **Edit > Copy.**

Switch to your new, blank Web page, click in the document window and choose **Edit > Paste.**

The Word text is pasted without formatting into the page.

**Macintosh only** Each paragraph is separated by a line break. To create a blank line between paragraphs, highlight each BR character and then press the Return or Enter key. If the BR character is not visible then choose **Edit > Preferences > Invisible Elements** and then check the Line Breaks box. (For large documents Find and Replace can be used.)

**NOTE!** If paragraphs are **NOT** separated by a blank line, then use the method describe in the paragraph above to replace the BR character.

At the top of the page highlight the text [http://www.inventorsdigest.com/magazine/freearticles/geniuses.html](http://www.inventorsdigest.com/magazine/freearticles/geniuses.html), making sure not to include leading or trailing spaces, and then create a link for the Web address in the Property Inspector.

Choose **target qualifier _blank.**

Choose **File > Save.**

Preview the page in a Web browser and then click the investorsdigest.com address link. The page should display in a separate browser window.

Close the eniac_women Web page.

**Exit** or **Quit** Microsoft Word.

**Wrapping Images Around Text**

In this section you will learn how to attach a caption to an image and then wrap the image to the right of the paragraphs below. This technique is an alternative to placing images and text side-by-side using a two-column table.

In the Site window double-click **womenincomputing.html** to open it. The page includes content previously completed in the *Dreamweaver Basics* tutorial with newly added items.

As you work through the next series of steps refer to the figure *Lovelace aligned right.*
− Click to the left of the anchor before Pioneers (make sure that the anchor is not highlighted.

**Pioneers**

Place the cursor to the left of the anchor

− Choose **Insert > Table** and enter the values (including the 0’s) as shown in figure **Ada image table**:

  ![Insert Table](image)

  Ada image table

− Click **OK** to insert the table. Drag the Ada image into the table’s cell.

− In the second paragraph select the text:

  o Evelyn Silva scanned this from a picture she found "in the trash" in Lousianna, USA, and submitted it to the Ada Picture Gallery in October 2000.

− Choose **Edit > Cut**.

− Click inside the table to the right of the image and in the Property Inspector choose **Vert = top** and **Bg (background) = #CCCCCC** (figure table attributes).

  ![table attributes](image)

  table attributes

− Press **Shift + Enter** and then choose **Edit > Paste** to place the text just below the image inside the table.

− Make sure that the text is still selected. In the Property Inspector choose **Font (A) = Verdana, Arial, ...**, **Size = 1**, and **Text Color = #333333** (figure font settings).
Make sure that the cursor is still inside the table. Click the \texttt{<table>} tag in the Tag Selector to select the table.

In the Property Inspector change the table width from 200 to 173. Choose \texttt{Align = Right} to wrap the table (with the image and caption inside) to the right of the text below.

If the Standard toolbar is not visible, choose \texttt{View > Toolbars > Standard}.

Choose \texttt{File > Save} or click the Save button in the Standard toolbar.
Pop-up Image

In this section you will apply a hyperlink to an embedded thumbnail image that, when clicked, will display a larger size of the image in a separate Web page. This technique is effective when the image is too large to display in the original page.

- Click to the left of the “Admiral Hopper” heading and choose Insert > Image. Navigate to the images folder in your site folder and choose hopper_thumb.jpg. Click Choose or OK.

- Make sure the image is selected and In the Property Inspector choose Align = Left, type 0 in the Border box, type images/hopper.jpg in the Link box, and choose Target = _blank. Refer to figure thumbnail settings. The border is set to 0 to prevent a colored border around the image.

- Preview the page in Firefox or Internet Explorer.

- Click the thumbnail image link to open the larger image in a new Web page. Click the close button to close the page.

Table Layout for Heading, Images, and Text

In the Dreamweaver Basics and this tutorial you have worked with a number of table techniques to layout columns of text, position text and images side-by-side, and create a captioned image. In this section you will learn how to merge table cells to provide a flexible layout for text, images, and headings.

As you work through this section, refer to the figure Erna Hoover table.

- Choose File > New ...

- Click the General tab, click Basic Page under Category, click HTML under Basic Page, and click Create.

- Make sure that the Show Design View button is selected.

- Type Erna Schneider Hoover in the Title box at the top of the page.
Save your Web page
Choose File > Save and navigate to your folder:

Mtwain08$:mysite (Macintosh) or R:\mysite (Windows).

Type the filename hoover.html in the File Name box and click the Save button.

Click in the document window.

Choose Insert > Table and enter these settings in the dialog box:

Select the two cells in the table’s first row and click the Property Inspector’s Merge table button.

Likewise, select the two cells in the bottom row and merge them.

In the top table row, type ERNA SCHNEIDER HOOVER – Inventor of first computer telephone switch. Note that the name is all upper case.

Drag your mouse to highlight the text. In the Property Inspector’s Text Color box type #993300, which is a brownish, Web safe color.

Choose Font = Arial, Helvetica ... choose Size = 2, and click the Bold button.

In the Background Color box type #FFCCCC, which is a pale pink color.

In table’s second row set the width of the first column to 200 and the second column to 360.

Click the first column and insert the image hoover.gif from your images folder. Center the image using the Align Center button in the Property Inspector.

Open the page hoover_text.html from your site directory.
Copy the first paragraph, then switch back to the page hoover.html and paste the paragraph into the second row's second column of your table.

Click just before the word “One”, which starts the paragraph. Insert the image hoover_switch.jpg. To align the image to the right of the text below, click once on the image and choose Align > Right in the Property Inspector.

Click in the table’s last row and paste the second, third, and fourth paragraphs from hoover_text.html.

Save your Web page.

Close the page hoover_text.html.
Outside Table Borders

Table borders apply not only to the outside of the table but also to the surrounding edges of the inside cells. You will learn yet another technique that provides the illusion of an outer edge border by surrounding the current table with a single cell table.

- Click the right of the Hoover table and press the Enter key.
- Choose Insert > Table and enter the settings to the right and click OK.

- In the Property Inspector type Bg Color = #FFCCCC.
- Click inside the new table and click the Center button.
- Click inside the Hoover table and click the <table> tag in the Tag Selector.
- Choose Edit > Cut, click inside the new table, and then choose Edit > Paste to place the Hoover table inside.
- Click the <table> tag in the Tag Selector that selects the outer table. In Property Inspector remove 20 from the Width box to make the value blank.
- Preview the page in your Web browser. The outer cell background shows through the cells of the Hoover table.
- Return to Dreamweaver. Change the following cells to white. Select the three cells below the top row in the Hoover table and choose white for the background color (Bg = #FFFFFF in the Property Inspector).
- Use the Tag Selector to select the outer table. Experiment with the Cell Space by trying different sizes such as 4, 8, and 12, then preview the Web page each time. As the Cell Space increase, the outer table expands increasing the width of the Hoover table’s pseudo border.
Save the Web page and close it.

Inserting QuickTime Media

Web pages, of course, can include more than text, tables, images, and hyperlinks. You can substantially enliven a page with animations, slideshows, videos, and sounds. QuickTime is a popular, multimedia format that is especially suitable for working with Web pages. Embedded QuickTime media allow the reader to play movies and browse associated images and text all in one page.

As you work through this section refer to the figure Minerva’s Machine video clip at the end of this section.

- Open the page minervasmachine.html from your site window.
- Click after the end of the words “even fewer minorities than women” in the fifth paragraph and press the Enter key.
- Choose Insert > Table and enter these settings:

  ![Insert Table](image)

  - In the Property Inspector type Bg Color = #336633, which is a green shade.

  ![Property Inspector](image)

  - Click inside the table and click the Align Center button in the Property Inspector.
  - Choose Insert > Media > Plugin. Locate the movie minerva.mov in the media folder and click Choose or OK.
The dimensions of the movie are 160 x 120. Enter 160 in the W box and 140 in the H box (20 extra vertical pixels are needed to display the controller).

Click the Parameters button. Click the Add + button and type \textit{autoplay} under Parameter and \textit{false} under Value.

Click the \textbf{OK} button. In the Property Inspector click the \textbf{Play} button. The movie’s first frame should display in the page. Use the controller to test the movie’s playback.

Inside the green table, click to the right of the video and press Shift + Return. Type 
\textit{Click the Play button}, highlight the text, choose \textit{Font = Verdana, Size = 1}, and \textit{Text Color = #FFFFFF} (white). In the Property Inspector make sure that the text format is None (and not paragraph).

Make sure that the cursor is inside the table. In the Tag Selector choose \texttt{<table>} to select the table and video together. Choose \textbf{Align Right} in the Property Inspector to
wrap the table to the right of the text below. You may have to remove extra blank lines above the paragraph on the left.

- Preview the page with your Web browser, scroll down to the video, and click to play it. Adjust the sound if necessary.

The QuickTime movie is 1.9MB in size, which plays well using a high speed network. A modem connection would take nearly five minutes (refer to the size and download time to the right of the connection window) to load the Web page and the entire movie. Although not covered in this tutorial, there are a number of techniques that allow the reader to browse a Web page before loading a movie associated with that page. For examples, go to http://ecweb/it/ats/showcase

Minerva’s Machine video clip

- Close minervasmachine.html.

Libraries and Templates

Dreamweaver Libraries and Templates are powerful tools that automate the design and maintenance of a Web site, resulting in considerable time savings for those who regularly create and edit pages. Webmasters and members of site design teams will find these tools indispensible for their work. The next sections will show you how to use existing Libraries and Templates and help you understand their value. At the end of the tutorial are resources for learning how to create the two for your personal use.

Inserting Library Items

Library items are reusable chunks of HTML code that can be copied into any page of your Web site. You can include entire tables, sections of text, page headers, and page footers. In this section you will use a predesigned table that was copied into your site’s Library folder to place text and photographs side-by-side.
Open the **eniac_women.html** Web page.

The **Assets panel** displays all image files, colors, links, library items, and templates for the entire site. Refer to the figure **Assets Panel > Library** as you work through these steps.

- **Macintosh only** - Choose **Window > Assets**.

- **Windows only** - Click the **Assets** tab.

In the left sidebar are objects that organize and display site files by categories.

- Click the Library object to display all Library items for the Women in Computing Web site.

- **Windows only** - Click the **Site** tab to bring up the Site window.

- In the Eniac Women page, choose **Edit > Find and Replace**.

- Type **crutch of trajectory** in the Search for Text box. Make sure that Find in = **Current Document** Search For = **Text**. Click the **Find Next** button.
Click after the paragraph ending with “crutch of trajectory analysis”. The insertion point should be before the words “U.S. Army Photo”.

Make sure that the **Assets** window is visible. If not, then choose it from the Window menu. Click the **Library** icon to bring up the Library items.

The item **photo_text** is a three column table with a gray background that includes preset widths and alignments. This arrangement allows you to easily position photographs and text side-by-side.

Drag **photo_text** to the insertion point in your page. Click the **Detach from Original** button in the Property Inspector (refer to figure **Detach from Original**).

- Click **OK** to make it editable and discard automatic updates.

Click in the left cell of the **inner** table and choose **Insert > Image**. Locate the image **wndawmn_women_hist.jpg** in your site’s images folder and then click **OK** to insert it.

In the Alt box of the Property Inspector panel type **Photograph of the Eniac Women**. When displayed on a Web page, ALT text can be read by voice readers with other text to assist readers with vision disabilities. The text is also briefly displayed in your Web browser when the pointer is moved over the graphic.
Select the descriptive paragraph “U.S. Army Photo The First Four:” and move it to the inner table’s right cell.

Arrange the description with bulleted lines for each woman in the photo. Refer to figure Eniac Women photo and description.

Bold face the text U.S. Army Photo.

Remove any blank lines above and below the table.

Save your Web page.

Preview with Firefox or Internet Explorer.

Close eniac_women.html.

Applying Templates to a Page

A template is a special Web page that includes a predefined layout that is applied to a group of Web pages and, in some cases, an entire site. When you apply a template to a Web page, the resulting page inherits all of the template’s characteristics. Your page’s unique content (typically text and one or two images) is automatically placed into the template’s editable region.

The dwtutor template, which we will use in the next section, allows your primary content to be inserted into the ENTER CONTENT HERE region.

You have three regions where you typically enter data—the title box at the top of the page, the PageTitle region in the top green bar, and the content region where primary text and images are placed. These are referred to as editable regions. There is also the editable region “NAV”, located below the Eniac Women link in the side navigation bar that is reserved for
a menu item of your choice. The remaining sections of your page, referred to as **noneditable** regions, can only be modified by editing the *dwtutor.dwt* template file, which is located in the Templates folder of your site.

Open the page `womenincomputing.html` from your site window.

Choose **Modify > Templates > Apply Template** To Page. Choose the template *dwtutor*. Check **Update Page When Template Changes** and click the **Select** button.

To match your content to the template’s editable region Select **Document body** and choose **content** from Move Content to New Region. Refer to the figure *Inconsistent Region Name*.

If **Document Title** appears under **Editable Regions**, then select it and choose **Nowhere** from Move Content to New Region.
Inconsistent Region Names

- Click the OK button.

“Magically” your page has been converted to the Women in Computing layout, providing the consistency that is so critical to a professional Web site.

- In the Title box, type Women in Computing.

- Type WOMEN IN COMPUTING in the PageTitle region.

- Save womenincomputing.html.

Fixing a Table

Your page uses Cascading Style Sheets (CSS), a new technology that addresses many of the limitations of HTML. For example, CSS provide greater control over fonts and their sizes, line spacing, table backgrounds, and table borders. An external style sheet, which is a file of style descriptions in your site, can be used to format all your pages with few clicks of a mouse. Creating style sheets is an involved process that is beyond the scope of this tutorial. However, in this section you will practice applying predefined styles to text and tables in your Web pages.
Click in a cell in the top row of the Present Women in Computing table.

Switch to CSS edit mode by clicking the CSS/HTML toggle button to the right of the Format menu in The Property Inspector. The figure No CSS Style shows that no style has been applied within the table cell.

The default style Georgia 12 that was applied by the template to the page’s text did not format text inside tables. The style will have to be applied through a menu.

Use the Tag Selector at the bottom of the Document window to select the <table> tag.

Right click (Windows) or Control-click (Macintosh) on the tag and then choose Set Class > Verdana11.

Click again in a cell in the top row. Notice the style change in the menu (see figure CSS style applied).

It is always a good idea to toggle back to HTML mode when you have applied a style. Switch back to HTML mode by clicking the CSS/HTML Toggle button.

Click the <table.verdana11> tag and set the table’s border and cell space to 0 and reduce the cell padding to 8. The table now looks professional and is easier to read.

Using the technique that you learned in the section Outside Table Borders, create a new, one-cell table formatted with CellPad = 1 and Bg Color = #336633.

Set the Cell Background color #CCCCC (shade of green) for all cells in the Present Women in Computing table. Insert this table inside the new table (you may have to temporarily increase the new table’s CellPad size.

Apply the Heading 3 format to the headers Pioneers and Present Women in Computing. Heading 3 has been redefined as a style.

Save the Web page.
Applying the Template to the Remaining Pages

- For each of the remaining pages in your site, apply the dwtutor template, enter the titles in the Title box and PageTitle Region, and save the page. They are hoover.html, links.html, minervasmachine.html, and eniacwomen.html.

Creating a New Page from a Template

- Choose File > New
- In the New Document window, click the Templates tab.
- Click to select the site you want under “Templates for”. You currently have only one site, which is My Second Site.
- In the right pane, click to select the dwtutor template (make sure that Update page when Template Changes is checked), then click the Create button.
- Type Contact Me in the Title Box and in the Editable region PageTitle.
- Save the page as contact.html.
- Enter this text in the content area, replacing Mark Twain with your name.

  Women in Computing workshop site completed by Mark Twain.

  Please e-mail comments to
- Click to insert the cursor to the right of “comments to”.
- Click the E-mail Link icon in the Insert Bar. Type your elmira.edu e-mail address in the Text box and the same address in the E-mail box. (If you wish, you can type any text string in the Text box such as your full name.)

  Click the OK button to set the e-mail link. When a reader clicks the link on the Web server, then a new message is opened into the default e-mailer (e.g. Eudora, Outlook Express) with your address placed in the To: field.
Save the page.

Viewing your Site through a Web Server

Web pages **previewed in a browser** are viewed locally. Follow these instructions to process your pages through the College’s Web server, making them available from any networked computer on campus. (Keep in mind that pages can only be processed through a Web server if the site’s folder is properly set up on a share (e.g. dwtrain) recognized by the server.

- Open Firefox or Internet Explorer and type the Web address **http://ecweb/class2008/mtwain08/mysite** (replace class2008 with your class year — use staff or faculty if you are not a student — and mtwain08 with your username). Any networked computer on campus can access your site using this address.

Changing Filenames in your Site

Keep in mind that you should not move nor rename your site files and folders outside of Dreamweaver. Once a site has been defined, do any file maintenance in the site window.

- Click back to Dreamweaver and close all HTML files.
- In your site window change the name of womenincomputing.html to **index.html**.
- When prompted to update links in the following files, click the Update button. Dreamweaver automatically changes any filename references in other pages from womenincomputing.html to index.html.
- Open Firefox or Internet Explorer and type the Web address **http://ecweb/class2008/mtwain08/mysite** The site's home page Women in Computing displays without having to type the filename womenincomputing.html. The Web server allows the shortcut because it is programmed to recognize home pages that are named index.html.

Updating a Template Page

If you edit a template page, then any saved changes will automatically apply to those pages containing the template with the Update Page option checked. This option is checked by default when templates are applied to new or existing pages.

- Back in Dreamweaver, open the Templates folder in the site window, then double-click dwtutor.dwt to open the file.

The page looks similar to the HTML pages in your site, but is different in several ways. The document bar is labeled **<<Template>>** (**dwtutor.dwt**) and both editable and noneditable
regions can be modified. You have complete control over the page. Any saved changes to the template will update any template applied page in the site.

- Click in the row Eniac Women of the navigation bar to set your cursor in that row.
- Right-click (Windows) or Control-click (Macintosh) to pop up a menu of items that include options for tables.
- **Move the mouse**—but do **not** click or press the button—down to *Table* and over down to *Insert Rows or Columns* (see figure *Contextual menu for tables*).

![Contextual menu for tables](image)

- **Click once** to bring up the Insert Rows or Columns. Choose *Rows* and *Below* the Selection.

![Insert a row below](image)

- Click the **OK** button to insert a new row.
- In the new row type **Contact**.
- Highlight the text and in the Property Inspector’s Link box type **../contact.html** (see figure *Contact link added*).
The character sequence “../” refers to a file outside the folder of the currently opened file, which is `dwtutor.dwt`. In other words, `contact.html` is outside the Template folder.

- Save the template and click the Update button (figure `Updating template files`). All pages in the list below will automatically update and add the Contact menu item.

  ![Contact link added](image)

- **Adding a Menu Item to the Navigation Bar**
  - If you have not already done so, close `template.dwt` and all other open files.
  - In the site window open `index.html` (formerly `womenincomputing.html`).
  - Click in the NAV row, which is an editable region.
  - Type Erna Schneider Hoover, highlight the text, and then type `hoover.html` in the Property Inspector’s Link box.
  - Save the page. The page is not a template, so the new link will not apply to other pages.
Open Firefox or Internet Explorer and type the Web address
http://ecweb/class2008/mtwain08/mysite Navigate through the Web pages, testing
the links in your site.

Notice that the Contact and Hoover menu items are added to each page as a result
of your change to the dwtutor.dwt template in the previous section Updating a
Template Page.

Exit Dreamweaver

Choose File > Exit.

Log off the computer.